A new Wi-Fi exploit has been discovered and you should update all of your devices a.s.a.p.

That includes anything that uses wi-fi, from your desktop/laptop to tablet/cell phone. And yes, some devices will not be patched immediately so keep trying.

Microsoft has patched their software, from Windows 7 to 10, and Apple is currently working on getting their iOS patches up and running, having already released them for developers. But Android users may need to wait until November 6th, 2017 for an update.

In the case of Linux operating systems and routers, OpenBSD systems have already been patched and patches are available for Debian-based systems. But most of the router manufacturers are working on firmware updates so you’ll need to contact your Internet Provider or Router manufacturer for details on that.

The problem is the KRACK wi-fi vulnerability, which is an issue to anyone that accesses non-secured websites online and doesn’t use a Virtual Private Network to do so. But it should be noted that Android and Linux users are more vulnerable to the exploit than anyone else because most of the other desktop and laptop operating systems are more complex.

The good news is that if you rent a cable modem from your internet provider, it will be updated by your internet provider soon (if it isn’t already updated). And if you don’t use your tablet and phone to browse the net outside your home, you will likely not have an issue.

If you use public wi-fi services in hotels or at your local coffee shop/restaurant, then I would recommend keeping an eye on updates and getting a virtual private network set up on your device to encrypt your internet, including those unencrypted sites you browse on.

By the way, there’s no point in changing your wireless password but you should change your router’s admin password, especially if it’s been left at default. :-/